Issues with the Purging API
Incident Report for Stellate
Resolved
This incident has been resolved.
Posted Feb 29, 2024 - 14:07 UTC
Update
The fix has been rolled out to all nodes and the Fastly team is monitoring purges across their systems.
Posted Feb 29, 2024 - 13:33 UTC
Monitoring
Fastly has begun rolling out a fix and is monitoring purges on their systems. The current ETA for the system-wide rollout is ~12 hours.

As a (temporary) workaround, we recommend disabling `swr` for all cache rules.

We will continue monitoring this incident on our end and update this status page as we get additional information from the team at Fastly.
Posted Feb 29, 2024 - 01:08 UTC
Update
Fastly has added an incident to their status page, available at https://www.fastlystatus.com/incident/376338

They are still investigating the issue and looking for a fix.
Posted Feb 28, 2024 - 23:44 UTC
Update
We continue to look into this with the Fastly team. We have narrowed this down to an issue with purging, in which all purges are considered soft purges if the cache configuration includes swr (stale-while-revalidate) values.
Posted Feb 28, 2024 - 22:42 UTC
Investigating
We are currently looking into a potential issue with the Purging API not removing data from the cache. We are working with our infrastructure partners to investigate what is causing this.
Posted Feb 28, 2024 - 15:41 UTC
This incident affected: Purging API.