Issues with newly created custom domain names
Incident Report for Stellate
Resolved
This issue has now been resolved. All custom domain names created during this incident are working again and newly created custom domain names get properly provisioned as well. We will however continue to monitor this closely.
Posted Jan 03, 2022 - 17:25 UTC
Monitoring
Fastly identified the issue with newly created custom domain names for GraphCDN and deployed a fix.

We checked all custom domains from users who checked in with our support team and they are all working. We will continue to monitor the situation until we are certain this issue has been fully resolved.
Posted Jan 03, 2022 - 13:06 UTC
Investigating
We are currently looking into an issue with adding new custom domain names to GraphCDN services.

While the service continues to be accessible and working from the default $servicename.graphcdn.app, the newly added custom domain name responds with an HTTP/2 500 error and an error message detailing that direct connections are not allowed.

This does not impact existing custom domains that have been configured in the past.

We are working with the Fastly support team to identify the root cause for this and will push a fix once we have identified what change on our end, or on theirs, is causing this issue.

We apologize for the inconvenience and would advise using the `graphcdn.app` service URLs for the time being.
Posted Dec 31, 2021 - 17:28 UTC