Cache service is experiencing degraded performance for a small percentage of users
Resolved
Feb 24, 2026 at 10:31pm UTC
Our edge provider also rolling out additional updates to infra that should fix any issues left. If you see any issues please reach out to us.
Affected services
Updated
Feb 24, 2026 at 3:32pm UTC
Mitigation deployed for garbled responses issue
We have deployed a mitigation for the issue where some GraphQL responses were previously returned as garbled (compressed/binary) data.
The mitigation decodes gzip-encoded responses at the edge if necessary, ensuring that clients consistently receive valid JSON GraphQL responses.
Initial testing with multiple repeated requests confirms that all responses are now correctly parsed and no garbled responses are observed.
Affected services
Updated
Feb 24, 2026 at 12:51pm UTC
We have continued investigating this issue together with our infrastructure partners and have been able to further narrow down the root cause.
The issue is related to intermittent inconsistencies in how compressed responses are handled at the edge. In affected cases, responses may be delivered in a compressed format (e.g. gzip) without the appropriate Content-Encoding header, or may undergo unintended transformations that corrupt the compressed payload. This results in garbled or unreadable responses in the browser.
While initial findings suggested a possible correlation with Cloudflare proxying, we have since observed similar behavior in scenarios where Cloudflare is not involved. This indicates the issue may occur across multiple layers of the delivery path, and we are continuing to work closely with partners including Fastly to isolate and resolve it.
The overall error rate remains low (a small percentage of requests), but we understand the impact of these intermittent failures and are treating this with high priority.
We are actively working on mitigation strategies and will provide another update as soon as we have confirmed improvements or a full resolution.
Affected services
Updated
Feb 23, 2026 at 8:43am UTC
We are continuing to closely monitor the situation together with our infrastructure partners to ensure the issue is fully resolved and stable.
At this point, the rate of garbled (compressed) responses has significantly decreased, but we are keeping the incident open until we are confident the behavior has fully subsided.
We will provide another update once monitoring confirms full resolution.
Affected services
Updated
Feb 22, 2026 at 9:33am UTC
Investigating
We are currently investigating an issue where a small percentage of requests may return garbled (compressed) responses.
Our analysis indicates this may occur when traffic is proxied through Cloudflare. We are in contact with the provider and awaiting further clarification to ensure a stable resolution.
As a temporary workaround, users can switch their DNS records to DNS only (disable Cloudflare proxying), which appears to mitigate the issue.
We will provide further updates as soon as more information becomes available.
Affected services
Created
Feb 20, 2026 at 3:10pm UTC
Our internal caching service is partially impacted, causing some requests (including those to the Dashboard) to experience delayed or incorrectly compressed responses.
Affected services