Back to overview
Resolved

Scheduled infrastructure maintenance

Aug 16, 2026 at 8:00am UTC  –  Aug 16, 2026 at 8:38am UTC
Affected services
Production Stellate - Marketing Website
Production Stellate - Services
Stellate Dashboard

Resolved
Aug 16, 2026 at 8:38am UTC

Everything is now fully resolved. We completed the maintenance and verified everything afterward, all checks passed and everything is working smoothly and as expected. No issues were found.

Updated
Aug 16, 2026 at 8:38am UTC

Maintenance ended

Created
Aug 16, 2026 at 8:00am UTC

We will be performing scheduled maintenance on our infrastructure.

During the maintenance window, some Stellate services may experience brief interruptions or temporary degraded performance. We will closely monitor the system throughout the maintenance and work to minimize any impact.

No action is required from customers.